summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-23 03:33:52 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-23 03:33:52 +0000
commitb29d0c534a631b211f1f94168e7672c604c8f815 (patch)
treede1a41fed08e83a6b04cdbd211fef6054326999b /dbus/Makefile.am
parentb3a3969897930eeda308113acbbb3f98069ee1ab (diff)
2003-04-22 Havoc Pennington <hp@redhat.com>
* dbus/dbus-message.c, dbus/dbus-marshal.c: add 64-bit integer support, and do some code cleanups to share more code and speed up array marshal/demarshal. * dbus-1.0.pc.in (Cflags): put libdir include file in cflags * configure.in: generate dbus-arch-deps.h * dbus/dbus-protocol.h (DBUS_TYPE_INT64, DBUS_TYPE_UINT64): add 64-bit typecodes
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 9528b547..8dcb79dd 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -3,6 +3,7 @@ INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION \
-DDBUS_SYSTEM_BUS_PATH=\""@DBUS_SYSTEM_SOCKET@"\"
dbusincludedir=$(includedir)/dbus-1.0/dbus
+dbusarchincludedir=$(libdir)/dbus-1.0/include/dbus
lib_LTLIBRARIES=libdbus-1.la
@@ -21,6 +22,9 @@ dbusinclude_HEADERS= \
dbus-threads.h \
dbus-types.h
+dbusarchinclude_HEADERS= \
+ dbus-arch-deps.h
+
### source code that goes in the installed client library
### and is specific to library functionality
DBUS_LIB_SOURCES= \
@@ -116,6 +120,9 @@ libdbus_convenience_la_SOURCES= \
$(DBUS_SHARED_SOURCES) \
$(DBUS_UTIL_SOURCES)
+BUILT_SOURCES=$(dbusarchinclude_HEADERS)
+EXTRA_DIST=dbus-arch-deps.h.in
+
## this library is the same as libdbus, but exports all the symbols
## and is only used for static linking within the dbus package.
noinst_LTLIBRARIES=libdbus-convenience.la