summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-03-31 08:28:23 +0000
committerHavoc Pennington <hp@redhat.com>2003-03-31 08:28:23 +0000
commite6809d1a692da3b1127610b527f636743458274b (patch)
treed9c97aeaaee3a803fd7561c79acd01d6d5aec72a /dbus/Makefile.am
parent29c71168cd17b11eed65023c97aff401d5305b01 (diff)
2003-03-31 Havoc Pennington <hp@redhat.com>
* dbus/Makefile.am (INCLUDES): use EXPANDED_LOCALSTATEDIR to define DBUS_SYSTEM_BUS_PATH as we want to compile in the same final location that lands in the config file * bus/config-loader-expat.c (bus_config_load): fix type of XML_Parser variable * doc/TODO: remove TODO item for dbus_bus_get() * dbus/dbus-bus.c (bus_data_free): add missing lock/unlock
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 475f0cb7..c7a93b58 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -1,6 +1,6 @@
INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION \
- -DDBUS_SYSTEM_BUS_PATH=\""$(localstatedir)/@DBUS_SYSTEM_SOCKET@"\"
+ -DDBUS_SYSTEM_BUS_PATH=\""@EXPANDED_LOCALSTATEDIR@/@DBUS_SYSTEM_SOCKET@"\"
dbusincludedir=$(includedir)/dbus-1.0/dbus