summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael@ximian.com>2004-03-29 13:24:50 +0000
committerMichael Meeks <michael@ximian.com>2004-03-29 13:24:50 +0000
commitb498dbcc1af41796186e721bcfea916d9fccb2c5 (patch)
tree4a3829304b82100d4dd21097c37e273d53cadb48 /glib/Makefile.am
parent004b37eca4ed9a33269d4850525a0e1c2f5deaff (diff)
2004-03-29 Michael Meeks <michael@ximian.com>
* glib/dbus-gobject.c (set_object_property): split out / re-work, use the property type, and not the message type(!) (get_object_property): ditto. * glib/dbus-gvalue.c (dbus_gvalue_demarshal), (dbus_gvalue_marshal): make this code re-usable, needed for signals too, also on both proxy and server side. Re-write for more efficiency / readability.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index a45aa593..c594ece1 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -15,7 +15,9 @@ libdbus_glib_1_la_SOURCES = \
dbus-gtest.h \
dbus-gthread.c \
dbus-gutils.c \
- dbus-gutils.h
+ dbus-gutils.h \
+ dbus-gvalue.c \
+ dbus-gvalue.h
libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
## don't export symbols that start with "_" (we use this