summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@codefactory.se>2002-12-16 00:26:05 +0000
committerAnders Carlsson <andersca@codefactory.se>2002-12-16 00:26:05 +0000
commitc531a709f3b0f05c0a95aa932045d6e2209ae7b9 (patch)
tree22e198a761c88fb8ed13a382e943fb25b3bcb38c /glib/Makefile.am
parent3327ecfdcf6d3cd36b8b739282e9c0d2b768567a (diff)
2002-12-16 Anders Carlsson <andersca@codefactory.se>
* Makefile.am: * configure.in: Add GLib checks and fixup .pc files * glib/Makefile.am: * glib/dbus-glib.h: * glib/dbus-gmain.c: (gdbus_connection_prepare), (gdbus_connection_check), (gdbus_connection_dispatch), (gdbus_add_connection_watch), (gdbus_remove_connection_watch), (dbus_connection_gsource_new): * glib/dbus-gthread.c: (dbus_gmutex_new), (dbus_gmutex_free), (dbus_gmutex_lock), (dbus_gmutex_unlock), (dbus_gthread_init): * glib/test-dbus-glib.c: (message_handler), (main): Add GLib support.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
new file mode 100644
index 00000000..6f3906ce
--- /dev/null
+++ b/glib/Makefile.am
@@ -0,0 +1,26 @@
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS)
+
+dbusincludedir=$(includedir)/dbus-1.0/dbus
+
+lib_LTLIBRARIES=libdbus-glib-1.la
+
+dbusinclude_HEADERS= \
+ dbus-glib.h
+
+libdbus_glib_1_la_SOURCES = \
+ dbus-gmain.c \
+ dbus-gthread.c
+
+libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
+
+
+if DBUS_BUILD_TESTS
+
+noinst_PROGRAMS= test-dbus-glib
+
+test_dbus_glib_SOURCES= \
+ test-dbus-glib.c
+
+test_dbus_glib_LDADD= $(top_builddir)/glib/libdbus-glib-1.la
+
+endif