summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-01-31 02:55:12 +0000
committerHavoc Pennington <hp@redhat.com>2005-01-31 02:55:12 +0000
commitd2c1a633d15611eb6ca757863c489ebf201d07cd (patch)
treecbe676973f4cd3d5b79629aae343240a2a3e12a6 /glib/Makefile.am
parentd5b7d7a78c0fb2e41d5966a0778b08f8d8e35ea4 (diff)
2005-01-30 Havoc Pennington <hp@redhat.com>
* tools/dbus-names-model.c: dynamically watch NameOwnerChanged * autogen.sh: change to autotools 1.9 * glib/dbus-gproxy.c: completely change how signals work (dbus_g_proxy_add_signal): new function to specify signature of a signal (dbus_g_proxy_emit_received): marshal the dbus message to GValues, and g_warning if the incoming message has the wrong signature.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 4db47de4..6a42e6f9 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -5,6 +5,8 @@ lib_LTLIBRARIES=libdbus-glib-1.la
libdbus_glib_1_la_SOURCES = \
dbus-glib.c \
dbus-gmain.c \
+ dbus-gmarshal.c \
+ dbus-gmarshal.h \
dbus-gobject.c \
dbus-gproxy.c \
dbus-gtest.c \
@@ -41,6 +43,15 @@ dbus_binding_tool_SOURCES = \
dbus_binding_tool_LDADD= -lexpat libdbus-gtool.la
+## we just rebuilt these manually and check them into cvs; easier than
+## convincing automake/make to do this properly
+regenerate-built-sources:
+ @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --header > dbus-gmarshal.h && \
+ echo '#include "dbus-gmarshal.h"' > dbus-gmarshal.c && \
+ @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --body >> dbus-gmarshal.c
+
+EXTRA_DIST=dbus-gmarshal.list
+
if DBUS_BUILD_TESTS
## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we