summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2005-01-29 19:52:19 +0000
committerHavoc Pennington <hp@redhat.com>2005-01-29 19:52:19 +0000
commitfd3e49f249fb4ab5ac7da4fe9fc14cc67958d84a (patch)
treedbc9e553ccf466707acffb0f6f1e1f59177f1841 /glib/Makefile.am
parent602c4b05c4d1c7c83a459b7d0164cc14eebdfcb4 (diff)
2005-01-29 Havoc Pennington <hp@redhat.com>
* glib/Makefile.am: rename dbus-glib-tool to dbus-binding-tool; though it uses glib, it could be extended for any binding in principle * glib/dbus-gobject.c (gobject_message_function): change to the new way properties work * dbus/dbus-protocol.h: add the new interfaces * doc/dbus-specification.xml: document the introspection format, Introspectable interface, and add an org.freedesktop.Properties interface. * glib/dbus-gparser.c: add support for a <property> element * glib/dbus-gidl.c: add PropertyInfo * glib/dbus-gobject.c (handle_introspect): put the outermost <node> outside the signal and property descriptions. (introspect_properties): export properties as <property> rather than as method calls
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index e0362b42..4db47de4 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -34,12 +34,12 @@ libdbus_gtool_la_SOURCES = \
libdbus_gtool_la_LIBADD = libdbus-glib-1.la
-bin_PROGRAMS=dbus-glib-tool
+bin_PROGRAMS=dbus-binding-tool
-dbus_glib_tool_SOURCES = \
+dbus_binding_tool_SOURCES = \
dbus-glib-tool.c
-dbus_glib_tool_LDADD= -lexpat libdbus-gtool.la
+dbus_binding_tool_LDADD= -lexpat libdbus-gtool.la
if DBUS_BUILD_TESTS