summaryrefslogtreecommitdiffstats
path: root/glib/examples/statemachine/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2005-07-12 17:57:04 +0000
committerColin Walters <walters@verbum.org>2005-07-12 17:57:04 +0000
commit922d6bb194903583c6d8bb61ac0fc1a7077637b9 (patch)
treec4898b9b09259d508f5575a2dc59ce455314faeb /glib/examples/statemachine/Makefile.am
parent622cc8af6181d7e3d839ec0bdfad376648863844 (diff)
2005-07-12 Colin Walters <walters@verbum.org>
* glib/examples/statemachine/Makefile.am (statemachine-server-glue.h) (statemachine-glue.h): * glib/examples/Makefile.am (example-service-glue.h) (example-signal-emitter-glue.h): * glib/Makefile.am (dbus-glib-error-switch.h): Add libtool --mode=execute so we use the built library instead of any installed one.
Diffstat (limited to 'glib/examples/statemachine/Makefile.am')
-rw-r--r--glib/examples/statemachine/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/glib/examples/statemachine/Makefile.am b/glib/examples/statemachine/Makefile.am
index 11140b13..303808b6 100644
--- a/glib/examples/statemachine/Makefile.am
+++ b/glib/examples/statemachine/Makefile.am
@@ -19,10 +19,10 @@ statemachine_client_LDADD= $(top_builddir)/glib/libdbus-glib-1.la $(DBUS_GTK_THR
BUILT_SOURCES = statemachine-server-glue.h statemachine-glue.h
statemachine-server-glue.h: statemachine-server.xml
- $(top_builddir)/glib/dbus-binding-tool --prefix=sm_server --mode=glib-server --output=$@ $<
+ libtool --mode=execute $(top_builddir)/glib/dbus-binding-tool --prefix=sm_server --mode=glib-server --output=$@ $<
statemachine-glue.h: statemachine.xml
- $(top_builddir)/glib/dbus-binding-tool --prefix=sm_object --mode=glib-server --output=$@ $<
+ libtool --mode=execute $(top_builddir)/glib/dbus-binding-tool --prefix=sm_object --mode=glib-server --output=$@ $<
sm-marshal.c: Makefile sm-marshal.list
@GLIB_GENMARSHAL@ --prefix=sm_marshal $(srcdir)/sm-marshal.list --header --body > $@.tmp && mv $@.tmp $@