summaryrefslogtreecommitdiffstats
path: root/mono/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-06-22 22:59:31 +0000
committerHavoc Pennington <hp@redhat.com>2003-06-22 22:59:31 +0000
commit1cc184b4a849619b56bed2be0e752fbc0fb75a29 (patch)
tree867409e28e08152147e095606e487793873dd51e /mono/Makefile.am
parent958805418359aca169cd363a4a3279f0fdab753c (diff)
2003-06-22 Havoc Pennington <hp@pobox.com>
* mono/Connection.cs, mono/DBus.cs, mono/Error.cs: Start wrapping more stuff.
Diffstat (limited to 'mono/Makefile.am')
-rw-r--r--mono/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/mono/Makefile.am b/mono/Makefile.am
index d81bcc28..efd61b4b 100644
--- a/mono/Makefile.am
+++ b/mono/Makefile.am
@@ -3,16 +3,16 @@ DESTDIR=
DLLS=dbus-sharp.dll
NOINST_EXES=test-dbus-sharp
-DBUS_SHARP_FILES=Message.cs
+DBUS_SHARP_FILES= DBus.cs Message.cs Connection.cs Error.cs
TEST_DBUS_SHARP_FILES=Test.cs
all: $(DLLS) $(NOINST_EXES)
dbus-sharp.dll: $(DBUS_SHARP_FILES)
- $(MCS) $(MCSFLAGS) --unsafe --target library -o dbus-sharp.dll --recurse '$(DBUS_SHARP_FILES)'
+ $(MCS) $(MCSFLAGS) --unsafe --target library -o dbus-sharp.dll $(DBUS_SHARP_FILES)
test-dbus-sharp: $(TEST_DBUS_SHARP_FILES)
- $(MCS) $(MCSFLAGS) --unsafe --target exe -L . -r dbus-sharp.dll -o test-dbus-sharp --recurse '$(TEST_DBUS_SHARP_FILES)'
+ $(MCS) $(MCSFLAGS) --unsafe --target exe -L . -r dbus-sharp.dll -o test-dbus-sharp $(TEST_DBUS_SHARP_FILES)
clean:
rm -f $(DLLS) $(NOINST_EXES)