summaryrefslogtreecommitdiffstats
path: root/mono/Makefile.am
diff options
context:
space:
mode:
authorJon Trowbridge <trow@ximian.com>2004-08-31 03:59:14 +0000
committerJon Trowbridge <trow@ximian.com>2004-08-31 03:59:14 +0000
commit4a77a2dd972e817a08a4571220c8406709af8c48 (patch)
tree9a4ce9513836303b870b0f266f18b76900caa186 /mono/Makefile.am
parent3a78ce17957de8f56b33bd0d25c2974c740a3b8b (diff)
2004-08-30 Jon Trowbridge <trow@ximian.com>
* mono/BusDriver.cs: Added. This is a class for interacting with the org.freedesktop.DBus service. * mono/Message.cs: Added a mechanism to expose the message that is currently being dispatched via the static Message.Current property. Added Message.Sender and Message.Destination properties. * mono/Handler.cs: Expose the dispatched message via Message.Current when handling method calls. * mono/Service.cs: Expose the dispatched message via Message.Current when handling signal emissions. * mono/Connection.cs: Bind dbus_bus_get_base_service via the Connection.BaseService property.
Diffstat (limited to 'mono/Makefile.am')
-rw-r--r--mono/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/mono/Makefile.am b/mono/Makefile.am
index 8bb25f59..1d19ec01 100644
--- a/mono/Makefile.am
+++ b/mono/Makefile.am
@@ -9,6 +9,7 @@ ASSEMBLY_NAME=dbus-sharp
DBUS_SHARP_FILES= \
Arguments.cs \
Bus.cs \
+ BusDriver.cs \
Connection.cs \
Custom.cs \
DBusException.cs \