summaryrefslogtreecommitdiffstats
path: root/mono/Makefile.am
diff options
context:
space:
mode:
authorJoe Shaw <joeshaw@novell.com>2005-01-25 19:47:13 +0000
committerJoe Shaw <joeshaw@novell.com>2005-01-25 19:47:13 +0000
commitb0002eb697ec4b1e35846b51d9e6e1a7824e0b03 (patch)
treed14e5cdc6646cb3de31d6e9e9ded564ac7bff82a /mono/Makefile.am
parentf4d4d5ace5804acc363fbcff51fbdc82c078702b (diff)
2005-01-25 Joe Shaw <joeshaw@novell.com>
* Land the mono binding changes to conform to the new APIs. * mono/Makefile.am: Remove Custom.cs, DBusType/Custom.cs, DBusType/Dict.cs, and DBusType/Nil.cs from the build. * mono/Arguments.cs (GetCodeAsString): Added. Returns the dbus type code as a string. (InitAppending): Rename dbus_message_append_iter_init() to dbus_message_iter_init_append(). * mono/BusDriver.cs: Rename ServiceEventHandler to NameOwnerChangedHandler. Rename GetServiceOwner to GetOwner. Rename ServiceOwnerChanged to NameOwnerChanged. * mono/Connection.cs: Rename BaseService to UniqueName, and the underlying C call. * mono/Custom.cs: Removed. The CUSTOM type has been removed. * mono/Service.cs: Rename Exists to HasOwner, internally rename dbus_bus_acquire_service() to dbus_bus_request_name(). * mono/DBusType/Array.cs (ctor): Use Type.GetElementType() instead of Type.UnderlyingSystemType to get the correct element type for the array. (ctor): Update code for new APIs: use dbus_message_iter_recurse(), dbus_message_get_{element|arg}_type() instead of dbus_message_iter_init_array_iterator(). (Append): Replace dbus_message_iter_append_array() with dbus_message_iter_open_container() and dbus_message_iter_close_container(). * mono/DBusType/Custom.cs, mono/DBusType/Nil.cs: Removed. These types have been removed. * mono/DBusType/*.cs: Replace calls of dbus_message_iter_get_[type]() to dbus_message_iter_get_basic(), but specify the type in the DllImport extern declaration. Ditto for dbus_message_iter_append_[type]() -> dbus_message_iter_append_basic(). * mono/example/BusListener.cs: Update for ServiceEventHandler -> NameOwnerChangedHandler.
Diffstat (limited to 'mono/Makefile.am')
-rw-r--r--mono/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/mono/Makefile.am b/mono/Makefile.am
index 0a53f746..02223f1a 100644
--- a/mono/Makefile.am
+++ b/mono/Makefile.am
@@ -10,7 +10,6 @@ DBUS_SHARP_FILES= \
$(srcdir)/Bus.cs \
$(srcdir)/BusDriver.cs \
$(srcdir)/Connection.cs \
- $(srcdir)/Custom.cs \
$(srcdir)/DBusException.cs \
$(srcdir)/Error.cs \
$(srcdir)/ErrorMessage.cs \
@@ -31,12 +30,9 @@ DBUS_SHARP_FILES= \
$(srcdir)/DBusType/Array.cs \
$(srcdir)/DBusType/Boolean.cs \
$(srcdir)/DBusType/Byte.cs \
- $(srcdir)/DBusType/Custom.cs \
- $(srcdir)/DBusType/Dict.cs \
$(srcdir)/DBusType/Double.cs \
$(srcdir)/DBusType/Int32.cs \
$(srcdir)/DBusType/Int64.cs \
- $(srcdir)/DBusType/Nil.cs \
$(srcdir)/DBusType/ObjectPath.cs \
$(srcdir)/DBusType/String.cs \
$(srcdir)/DBusType/UInt32.cs \