summaryrefslogtreecommitdiffstats
path: root/mono/Makefile.am
diff options
context:
space:
mode:
authorOwen Fraser-Green <owen@discobabe.net>2004-03-23 12:10:32 +0000
committerOwen Fraser-Green <owen@discobabe.net>2004-03-23 12:10:32 +0000
commitc916037773d7d3d8d37ca2c5a8899b7b728e377d (patch)
tree21c37372ab9795583e724e8459578b7fe0be330b /mono/Makefile.am
parent2195cf0dbde2ae26b5a684c6d914c1711f44c28d (diff)
First checkin of the Mono bindings.
Diffstat (limited to 'mono/Makefile.am')
-rw-r--r--mono/Makefile.am40
1 files changed, 36 insertions, 4 deletions
diff --git a/mono/Makefile.am b/mono/Makefile.am
index efd61b4b..6483f4ed 100644
--- a/mono/Makefile.am
+++ b/mono/Makefile.am
@@ -1,9 +1,41 @@
DESTDIR=
DLLS=dbus-sharp.dll
-NOINST_EXES=test-dbus-sharp
+NOINST_EXES=test-dbus-sharp.exe
+
+DBUS_SHARP_FILES= \
+ Arguments.cs \
+ Bus.cs \
+ Connection.cs \
+ Custom.cs \
+ DBusException.cs \
+ Error.cs \
+ Handler.cs \
+ InterfaceAttribute.cs \
+ Introspector.cs \
+ Message.cs \
+ MethodAttribute.cs \
+ MethodCall.cs \
+ MethodReturn.cs \
+ ProxyBuilder.cs \
+ Server.cs \
+ Service.cs \
+ Signal.cs \
+ DBusType/IDBusType.cs \
+ DBusType/Array.cs \
+ DBusType/Boolean.cs \
+ DBusType/Byte.cs \
+ DBusType/Custom.cs \
+ DBusType/Dict.cs \
+ DBusType/Double.cs \
+ DBusType/Int32.cs \
+ DBusType/Int64.cs \
+ DBusType/Nil.cs \
+ DBusType/ObjectPath.cs \
+ DBusType/String.cs \
+ DBusType/UInt32.cs \
+ DBusType/UInt64.cs
-DBUS_SHARP_FILES= DBus.cs Message.cs Connection.cs Error.cs
TEST_DBUS_SHARP_FILES=Test.cs
all: $(DLLS) $(NOINST_EXES)
@@ -11,8 +43,8 @@ all: $(DLLS) $(NOINST_EXES)
dbus-sharp.dll: $(DBUS_SHARP_FILES)
$(MCS) $(MCSFLAGS) --unsafe --target library -o dbus-sharp.dll $(DBUS_SHARP_FILES)
-test-dbus-sharp: $(TEST_DBUS_SHARP_FILES)
- $(MCS) $(MCSFLAGS) --unsafe --target exe -L . -r dbus-sharp.dll -o test-dbus-sharp $(TEST_DBUS_SHARP_FILES)
+test-dbus-sharp.exe: $(TEST_DBUS_SHARP_FILES)
+ $(MCS) $(MCSFLAGS) --unsafe --target exe -L . -r dbus-sharp.dll -r gtk-sharp.dll -o test-dbus-sharp.exe $(TEST_DBUS_SHARP_FILES)
clean:
rm -f $(DLLS) $(NOINST_EXES)