summaryrefslogtreecommitdiffstats
path: root/qt3/Makefile.am
diff options
context:
space:
mode:
authorHarald Fernengel <harry@kdevelop.org>2005-09-30 15:20:08 +0000
committerHarald Fernengel <harry@kdevelop.org>2005-09-30 15:20:08 +0000
commit57b6fd3894d0563e0dcc64bc498067ef69f61291 (patch)
tree22fe337ecb429e28a1197de80b19ada1a112ff35 /qt3/Makefile.am
parentfe9f471950c7a061289efe734c20074d5c357f20 (diff)
bring Qt3 library back. Some apps that are not in the KDE trunk are using it.
Diffstat (limited to 'qt3/Makefile.am')
-rw-r--r--qt3/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/qt3/Makefile.am b/qt3/Makefile.am
new file mode 100644
index 00000000..01b619a0
--- /dev/null
+++ b/qt3/Makefile.am
@@ -0,0 +1,37 @@
+if HAVE_QT3
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_QT3_CXXFLAGS)
+
+dbusincludedir=$(includedir)/dbus-1.0/dbus
+
+lib_LTLIBRARIES=libdbus-qt-1.la
+
+dbusinclude_HEADERS= \
+ dbus-qt.h message.h connection.h \
+ server.h
+
+libdbus_qt_1_la_SOURCES = \
+ $(top_srcdir)/qt3/dbus-qthread.cpp \
+ $(top_srcdir)/qt3/message.cpp \
+ $(top_srcdir)/qt3/connection.cpp \
+ $(top_srcdir)/qt3/integrator.cpp \
+ $(top_srcdir)/qt3/server.cpp \
+ $(top_srcdir)/qt3/connection.h \
+ $(top_srcdir)/qt3/integrator.h \
+ $(top_srcdir)/qt3/server.h
+
+
+$(top_srcdir)/qt3/connection.cpp: connection.moc
+$(top_srcdir)/qt3/integrator.cpp: integrator.moc
+$(top_srcdir)/qt3/server.cpp: server.moc
+$(top_srcdir)/qt3/connection.h: connection.moc
+$(top_srcdir)/qt3/integrator.h: integrator.moc
+$(top_srcdir)/qt3/server.h: server.moc
+
+CLEANFILES=connection.moc integrator.moc server.moc
+
+libdbus_qt_1_la_LIBADD= $(DBUS_QT3_LIBS) $(top_builddir)/dbus/libdbus-1.la
+libdbus_qt_1_la_LDFLAGS= -version-info 1:0 -no-undefined
+
+%.moc: %.h
+ $(QT3_MOC) $< > $@
+endif