summaryrefslogtreecommitdiffstats
path: root/test/glib/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-10-12 05:59:39 +0000
committerHavoc Pennington <hp@redhat.com>2003-10-12 05:59:39 +0000
commit4097e94af3d2fb1eb865343e3f76ca3949e7c69b (patch)
treec495c423b72fdb8421ec4266396efa97761fa590 /test/glib/Makefile.am
parent56cc4ae1a241d36b64dbe26de89714f7771f6e78 (diff)
2003-10-12 Havoc Pennington <hp@pobox.com>
Added test code that 1) starts an actual bus daemon and 2) uses DBusGProxy; fixed bugs that were revealed by the test. Lots more testing possible, but this is the basic framework. * glib/dbus-gproxy.c (dbus_gproxy_manager_unregister): remove empty proxy lists from the proxy list hash * dbus/dbus-message.c (dbus_message_iter_get_args_valist): add a couple of return_if_fail checks * dbus/dbus-pending-call.c (_dbus_pending_call_new): use dbus_new0 to allocate, so everything is cleared to NULL as it should be. * glib/dbus-gmain.c (dbus_connection_setup_with_g_main): pass source as data to dbus_connection_set_timeout_functions() as the timeout functions expected * test/glib/run-test.sh: add a little script to start up a message bus and run tests using it * tools/dbus-launch.1: updates * tools/dbus-launch.c (main): add --config-file option * tools/dbus-launch.c (main): remove confusing else if (runprog) that could never be reached. * dbus/dbus-message.c (dbus_message_new_method_return) (dbus_message_new_error, dbus_message_new_signal): set the no-reply-expected flag on all these. Redundant, but may as well be consistent.
Diffstat (limited to 'test/glib/Makefile.am')
-rw-r--r--test/glib/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/glib/Makefile.am b/test/glib/Makefile.am
index 9f900b13..608e7d01 100644
--- a/test/glib/Makefile.am
+++ b/test/glib/Makefile.am
@@ -1,5 +1,17 @@
INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) -I$(top_srcdir)/glib
+## note that TESTS has special meaning (stuff to use in make check)
+## so if adding tests not to be run in make check, don't add them to
+## TESTS
+if DBUS_BUILD_TESTS
+TESTS_ENVIRONMENT=DBUS_TOP_BUILDDIR=$(top_builddir) DBUS_TEST_HOMEDIR=$(top_builddir)/dbus
+TESTS=run-test.sh
+else
+TESTS=
+endif
+
+EXTRA_DIST=run-test.sh
+
if DBUS_BUILD_TESTS
if HAVE_GLIB_THREADS