summaryrefslogtreecommitdiffstats
path: root/test/name-test/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-03-02 22:24:28 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-03-02 22:24:28 +0000
commitda4182fb2976608bea64d676677681fdf2cd910b (patch)
tree0327d6778eb9743b8b11d13227ed2cc4f0e96430 /test/name-test/Makefile.am
parente6eea749eea428a33957b7129f920b9ae47090da (diff)
2006-03-02 John (J5) Palmieri <johnp@redhat.com>
* dbus/dbus-connection.c: (_dbus_connection_block_pending_call): Check to see if our data has already been read off the connection by another blocking pending call before we block in poll. (check_for_reply_and_update_dispatch_unlocked): Code taken from _dbus_connection_block_pending_call - checks for an already read reply and updates the dispatch if there is one. * test/name-test/test-pending-call-dispatch.c: New test for making sure we don't get stuck polling a dbus connection which has no data on the socket when blocking out of order on two or more pending calls.
Diffstat (limited to 'test/name-test/Makefile.am')
-rw-r--r--test/name-test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/name-test/Makefile.am b/test/name-test/Makefile.am
index 7e931c8a..34dd85a8 100644
--- a/test/name-test/Makefile.am
+++ b/test/name-test/Makefile.am
@@ -16,11 +16,18 @@ if DBUS_BUILD_TESTS
## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we
## build even when not doing "make check"
-noinst_PROGRAMS=test-names
+noinst_PROGRAMS=test-names test-pending-call-dispatch
test_names_SOURCES= \
test-names.c
test_names_LDADD=$(top_builddir)/dbus/libdbus-1.la $(top_builddir)/dbus/libdbus-convenience.la
+
+test_pending_call_dispatch_SOURCES = \
+ test-pending-call-dispatch.c
+
+test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-1.la $(top_builddir)/dbus/libdbus-convenience.la
+
+
endif