summaryrefslogtreecommitdiffstats
path: root/test/qt/Makefile.am
diff options
context:
space:
mode:
authorHarald Fernengel <harry@kdevelop.org>2005-09-30 15:05:33 +0000
committerHarald Fernengel <harry@kdevelop.org>2005-09-30 15:05:33 +0000
commitfe9f471950c7a061289efe734c20074d5c357f20 (patch)
treebb92653414d678553b7c62c94a374d4bb167213e /test/qt/Makefile.am
parent7183318f699c7d97af2bf5168cd6e051977f93cf (diff)
compile out of the box
Diffstat (limited to 'test/qt/Makefile.am')
-rw-r--r--test/qt/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/qt/Makefile.am b/test/qt/Makefile.am
index 553accd4..c8be4c2e 100644
--- a/test/qt/Makefile.am
+++ b/test/qt/Makefile.am
@@ -14,13 +14,13 @@ noinst_PROGRAMS= $(TEST_BINARIES)
qdbusconnection_SOURCES= \
tst_qdbusconnection.cpp
-$(top_srcdir)/test/qt/tst_qdbusconnection.cpp: tst_qdbusconnection.moc
+tst_qdbusconnection.cpp: tst_qdbusconnection.moc
-TEST_LIBS=$(DBUS_QTESTLIB_LIBS) $(top_builddir)/qt/libdbus-qt-1.la
+tst_qdbusconnection.moc:
+ $(QT_MOC) tst_qdbusconnection.cpp > tst_qdbusconnection.moc
+
+TEST_LIBS=$(DBUS_QTESTLIB_LIBS) $(top_builddir)/qt/libdbus-qt4-1.la
qdbusconnection_LDADD=$(TEST_LIBS)
CLEANFILES=tst_qdbusconnection.moc
-
-%.moc: %.cpp
- $(QT_MOC) $< > $@