summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2bf9a509..91c976e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,14 @@ EXTRA_DIST = \
all-local: Doxyfile
+if DBUS_BUILD_TESTS
+### nothing
+else
+check-local:
+ echo "You have to configure with --enable-tests to make check" ; \
+ exit 1
+endif
+
if DBUS_GCOV_ENABLED
clean-gcov:
find -name "*.da" -o -name "*.gcov" | xargs rm || true