summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 823d9cc4..9836ffd3 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -102,4 +102,12 @@ endif
#### Extra dist
-EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) \ No newline at end of file
+EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES)
+
+if DBUS_BUILD_TESTS
+### nothing
+else
+check-local:
+ echo "You have to configure with --enable-tests to make check" ; \
+ exit 1
+endif