summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 4648a31d..3b4f69db 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -25,12 +25,16 @@ endif
if DBUS_BUS_ENABLE_KQUEUE
DIR_WATCH_SOURCE=dir-watch-kqueue.c
else
+if DBUS_BUS_ENABLE_INOTIFY
+DIR_WATCH_SOURCE=dir-watch-inotify.c
+else
if DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX
DIR_WATCH_SOURCE=dir-watch-dnotify.c
else
DIR_WATCH_SOURCE=dir-watch-default.c
endif
endif
+endif
BUS_SOURCES= \
activation.c \