summaryrefslogtreecommitdiffstats
path: root/cmake/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/tools/CMakeLists.txt')
-rw-r--r--cmake/tools/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/cmake/tools/CMakeLists.txt b/cmake/tools/CMakeLists.txt
index c5568cb3..adff9306 100644
--- a/cmake/tools/CMakeLists.txt
+++ b/cmake/tools/CMakeLists.txt
@@ -38,9 +38,15 @@ set (dbus_monitor_SOURCES
../../tools/dbus-print-message.h
)
+if (WIN32)
+set (dbus_launch_SOURCES
+ ../../tools/dbus-launch-win.c
+)
+else (WIN32)
set (dbus_launch_SOURCES
../../tools/dbus-launch.c
)
+endif (WIN32)
set (dbus_cleanup_sockets_SOURCES
../../tools/dbus-cleanup-sockets.c
@@ -61,6 +67,10 @@ install_targets(/bin dbus-send${CMAKE_EXE_POSTFIX} )
# glib required
#add_executable(dbus_launch${CMAKE_EXE_POSTFIX} ${dbus_launch_SOURCES})
+add_executable(dbus-launch${CMAKE_EXE_POSTFIX} ${dbus_launch_SOURCES})
+target_link_libraries(dbus-launch${CMAKE_EXE_POSTFIX} )
+install_targets(/bin dbus-launch${CMAKE_EXE_POSTFIX} )
+
add_executable(dbus-monitor${CMAKE_EXE_POSTFIX} ${dbus_monitor_SOURCES})
target_link_libraries(dbus-monitor${CMAKE_EXE_POSTFIX} dbus-1)
install_targets(/bin dbus-monitor${CMAKE_EXE_POSTFIX} )