summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 67f971c6..c04097b5 100644
--- a/configure.in
+++ b/configure.in
@@ -700,8 +700,13 @@ else
# see if we have the SELinux header with the new D-BUS stuff in it
if test x$have_selinux = xyes ; then
- AC_EGREP_HEADER(DBUS__ACQUIRE_SVC, av_permissions.h,
+ AC_MSG_CHECKING([for DBUS Flask permissions in selinux/av_permissions.h])
+ AC_TRY_COMPILE([#include <selinux/av_permissions.h>],
+ [#ifdef DBUS__ACQUIRE_SVC return 0;
+ #else #error DBUS__ACQUIRE_SVC not defined
+ #endif],
have_selinux=yes, have_selinux=no)
+ AC_MSG_RESULT($have_selinux)
fi
if test x$enable_selinux = xauto ; then