summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 12 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 9f049bbb..1a826543 100644
--- a/configure.in
+++ b/configure.in
@@ -64,6 +64,7 @@ AC_ARG_ENABLE(mono, [ --enable-mono build mono bindings],en
AC_ARG_ENABLE(mono_docs, [ --enable-mono-docs build mono docs],enable_mono_docs=$enableval,enable_mono_docs=no)
AC_ARG_ENABLE(python, [ --enable-python build python bindings],enable_python=$enableval,enable_python=auto)
AC_ARG_ENABLE(selinux, [ --enable-selinux build with SELinux support],enable_selinux=$enableval,enable_selinux=auto)
+AC_ARG_ENABLE(dnotify, [ --enable-dnotify build with dnotify support (linux only)],enable_dnotify=$enableval,enable_dnotify=auto)
AC_ARG_WITH(xml, [ --with-xml=[libxml/expat] XML library to use])
AC_ARG_WITH(init-scripts, [ --with-init-scripts=[redhat] Style of init scripts to install])
@@ -829,21 +830,21 @@ else
fi
# dnotify checks
-if test x$target_os = xlinux-gnu; then
- AC_ARG_ENABLE(dnotify,
- [ --disable-dnotify Disable using dnotify on Linux],
- [case "${enableval}" in
- yes) dnotify=false ;;
- no) dnotify=true ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --disable-dnotify) ;;
- esac],[dnotify=true])
+if test x$enable_dnotify = xno ; then
+ have_dnotify=no;
+else
+ if test x$target_os = xlinux-gnu -o x$target_os = xlinux; then
+ have_dnotify=yes;
+ else
+ have_dnotify=no;
+ fi
fi
+
dnl check if dnotify backend is enabled
-if test x$dnotify = xtrue; then
+if test x$have_dnotify = xyes; then
AC_DEFINE(DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX,1,[Use dnotify on Linux])
fi
-
#### Set up final flags
DBUS_CLIENT_CFLAGS=
DBUS_CLIENT_LIBS=
@@ -1421,6 +1422,7 @@ echo "
Building GLib bindings: ${have_glib}
Building Python bindings: ${have_python}
Building SELinux support: ${have_selinux}
+ Building dnotify support: ${have_dnotify}
Building Mono bindings: ${enable_mono}
Building Mono docs: ${enable_mono_docs}
Building GTK+ tools: ${have_gtk}