summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dcb8d450..67b2dfa9 100644
--- a/configure.in
+++ b/configure.in
@@ -106,6 +106,11 @@ if test "x$GCC" = "xyes"; then
esac
case " $CFLAGS " in
+ *[\ \ ]-Wfloat-equal[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wfloat-equal" ;;
+ esac
+
+ case " $CFLAGS " in
*[\ \ ]-Wsign-compare[\ \ ]*) ;;
*) CFLAGS="$CFLAGS -Wsign-compare" ;;
esac