summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a411262e..48382b56 100644
--- a/configure.in
+++ b/configure.in
@@ -146,7 +146,10 @@ if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-Wfloat-equal[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -Wfloat-equal" ;;
+ *) if cc_supports_flag -Wfloat-equals; then
+ CFLAGS="$CFLAGS -Wfloat-equal"
+ fi
+ ;;
esac
case " $CFLAGS " in