summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 53ecf3d8..f8856a17 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,7 @@ AC_INIT(dbus/dbus.h)
AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE(dbus, 0.93.1)
+AM_INIT_AUTOMAKE(dbus, 0.94)
AM_CONFIG_HEADER(config.h)
@@ -187,6 +187,14 @@ if test "x$GCC" = "xyes"; then
;;
esac
+ case " $CFLAGS " in
+ *[\ \ ]-fPIC[\ \ ]*) ;;
+ *) if cc_supports_flag -fPIC; then
+ CFLAGS="$CFLAGS -fPIC"
+ fi
+ ;;
+ esac
+
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-ansi[\ \ ]*) ;;