summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index 9528b547..8dcb79dd 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -3,6 +3,7 @@ INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION \
-DDBUS_SYSTEM_BUS_PATH=\""@DBUS_SYSTEM_SOCKET@"\"
dbusincludedir=$(includedir)/dbus-1.0/dbus
+dbusarchincludedir=$(libdir)/dbus-1.0/include/dbus
lib_LTLIBRARIES=libdbus-1.la
@@ -21,6 +22,9 @@ dbusinclude_HEADERS= \
dbus-threads.h \
dbus-types.h
+dbusarchinclude_HEADERS= \
+ dbus-arch-deps.h
+
### source code that goes in the installed client library
### and is specific to library functionality
DBUS_LIB_SOURCES= \
@@ -116,6 +120,9 @@ libdbus_convenience_la_SOURCES= \
$(DBUS_SHARED_SOURCES) \
$(DBUS_UTIL_SOURCES)
+BUILT_SOURCES=$(dbusarchinclude_HEADERS)
+EXTRA_DIST=dbus-arch-deps.h.in
+
## this library is the same as libdbus, but exports all the symbols
## and is only used for static linking within the dbus package.
noinst_LTLIBRARIES=libdbus-convenience.la