summaryrefslogtreecommitdiffstats
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index f4175c79..b6b50d70 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -167,7 +167,7 @@ noinst_LTLIBRARIES=libdbus-convenience.la
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS)
## don't export symbols that start with "_" (we use this
## convention for internal symbols)
-libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined
## note that TESTS has special meaning (stuff to use in make check)
## so if adding tests not to be run in make check, don't add them to