summaryrefslogtreecommitdiffstats
path: root/gcj/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gcj/Makefile.am')
-rw-r--r--gcj/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/gcj/Makefile.am b/gcj/Makefile.am
index 8381afe6..608cdbe8 100644
--- a/gcj/Makefile.am
+++ b/gcj/Makefile.am
@@ -1,5 +1,19 @@
-noinst_PROGRAMS=hello
+SUBDIRS=org
+JAR=jar
-hello_SOURCES=Hello.java
+CLEANFILES=dbus-1.jar
-hello_LDFLAGS=--main=Hello
+dbus-1.jar:
+ -@rm -f dbus-1.jar
+ find org -type d -o -type f -name '*.class' | \
+ sed -e '/\/\./d' | \
+ $(JAR) cfM0E@ $@
+
+jardir = $(datadir)/java
+jar_DATA = dbus-1.jar
+
+noinst_PROGRAMS = test-message
+
+test_message_SOURCES = TestMessage.java
+test_message_LDFLAGS = --main=TestMessage
+test_message_LDADD = $(top_builddir)/gcj/org/freedesktop/dbus/libdbus-gcj-1.la