summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am33
1 files changed, 22 insertions, 11 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index d9edf6f5..ebdb932f 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -13,21 +13,11 @@ libdbus_glib_1_la_SOURCES = \
libdbus_glib_1_la_LIBADD= $(DBUS_GLIB_LIBS) $(top_builddir)/dbus/libdbus-1.la
-
if DBUS_BUILD_TESTS
if HAVE_GLIB_THREADS
- THREAD_APPS=test-thread-server test-thread-client
-endif
-
-noinst_PROGRAMS= test-dbus-glib $(THREAD_APPS)
-
-test_dbus_glib_SOURCES= \
- test-dbus-glib.c
-
-test_dbus_glib_LDADD= $(top_builddir)/glib/libdbus-glib-1.la
+THREAD_APPS=test-thread-server test-thread-client test-profile
-if HAVE_GLIB_THREADS
test_thread_server_SOURCES= \
test-thread-server.c \
test-thread.h
@@ -41,4 +31,25 @@ test_thread_client_SOURCES= \
test_thread_client_LDADD= $(DBUS_GLIB_THREADS_LIBS) $(top_builddir)/glib/libdbus-glib-1.la
endif
+noinst_PROGRAMS= test-dbus-glib $(THREAD_APPS)
+
+test_dbus_glib_SOURCES= \
+ test-dbus-glib.c
+
+test_dbus_glib_LDADD= $(top_builddir)/glib/libdbus-glib-1.la
+
+else
+### not building tests
+
+if HAVE_GLIB_THREADS
+noinst_PROGRAMS=test-profile
+endif
+
endif
+
+if HAVE_GLIB_THREADS
+test_profile_SOURCES= \
+ test-profile.c
+
+test_profile_LDADD= $(DBUS_GLIB_THREADS_LIBS) $(top_builddir)/glib/libdbus-glib-1.la
+endif \ No newline at end of file