summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 6d81e7d1..4cfea7f0 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -2,6 +2,9 @@ INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_T
lib_LTLIBRARIES=libdbus-glib-1.la
+libdbus_glib_HEADERS = dbus-glib-bindings.h
+libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
libdbus_glib_1_la_SOURCES = \
dbus-glib.c \
dbus-gmain.c \
@@ -47,6 +50,11 @@ dbus_binding_tool_SOURCES = \
dbus_binding_tool_LDADD= -lexpat libdbus-gtool.la
+dbus-glib-bindings.h: $(top_builddir)/bus/dbus-bus-introspect.xml dbus-binding-tool
+ ./dbus-binding-tool --mode=glib-client --output=dbus-glib-bindings.h $(top_builddir)/bus/dbus-bus-introspect.xml
+
+BUILT_SOURCES = dbus-glib-bindings.h
+
## we just rebuilt these manually and check them into cvs; easier than
## convincing automake/make to do this properly
regenerate-built-sources: