summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 4db47de4..6a42e6f9 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -5,6 +5,8 @@ lib_LTLIBRARIES=libdbus-glib-1.la
libdbus_glib_1_la_SOURCES = \
dbus-glib.c \
dbus-gmain.c \
+ dbus-gmarshal.c \
+ dbus-gmarshal.h \
dbus-gobject.c \
dbus-gproxy.c \
dbus-gtest.c \
@@ -41,6 +43,15 @@ dbus_binding_tool_SOURCES = \
dbus_binding_tool_LDADD= -lexpat libdbus-gtool.la
+## we just rebuilt these manually and check them into cvs; easier than
+## convincing automake/make to do this properly
+regenerate-built-sources:
+ @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --header > dbus-gmarshal.h && \
+ echo '#include "dbus-gmarshal.h"' > dbus-gmarshal.c && \
+ @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --body >> dbus-gmarshal.c
+
+EXTRA_DIST=dbus-gmarshal.list
+
if DBUS_BUILD_TESTS
## we use noinst_PROGRAMS not check_PROGRAMS for TESTS so that we