summaryrefslogtreecommitdiffstats
path: root/mono/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mono/Makefile.am')
-rw-r--r--mono/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/mono/Makefile.am b/mono/Makefile.am
new file mode 100644
index 00000000..d81bcc28
--- /dev/null
+++ b/mono/Makefile.am
@@ -0,0 +1,25 @@
+DESTDIR=
+
+DLLS=dbus-sharp.dll
+NOINST_EXES=test-dbus-sharp
+
+DBUS_SHARP_FILES=Message.cs
+TEST_DBUS_SHARP_FILES=Test.cs
+
+all: $(DLLS) $(NOINST_EXES)
+
+dbus-sharp.dll: $(DBUS_SHARP_FILES)
+ $(MCS) $(MCSFLAGS) --unsafe --target library -o dbus-sharp.dll --recurse '$(DBUS_SHARP_FILES)'
+
+test-dbus-sharp: $(TEST_DBUS_SHARP_FILES)
+ $(MCS) $(MCSFLAGS) --unsafe --target exe -L . -r dbus-sharp.dll -o test-dbus-sharp --recurse '$(TEST_DBUS_SHARP_FILES)'
+
+clean:
+ rm -f $(DLLS) $(NOINST_EXES)
+
+install: all
+ ../mkinstalldirs $(DESTDIR)$(prefix)/lib && \
+ cp $(DLLS) $(DESTDIR)$(prefix)/lib || exit 1
+
+EXTRA_DIST=$(DBUS_SHARP_FILES)
+