summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 25191630..3fd678b3 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -16,7 +16,8 @@ nodist_dbus_bindings_la_SOURCES = dbus_bindings.c
EXTRA_DIST = \
dbus_h_wrapper.h \
dbus_bindings.pyx.in \
- extract.py
+ extract.py \
+ lvalue_cast_post_process.py
CLEANFILES = \
dbus_bindings.pyx \
@@ -26,5 +27,7 @@ CLEANFILES = \
dbus_bindings.pyx: dbus_bindings.pyx.in extract.py
-$(PYTHON) extract.py dbus_bindings.pyx.in -I$(top_builddir) > dbus_bindings.pyx
-dbus_bindings.c: dbus_bindings.pyx
+dbus_bindings.c: dbus_bindings.pyx lvalue_cast_post_process.py
-pyrexc dbus_bindings.pyx
+ -$(PYTHON) lvalue_cast_post_process.py dbus_bindings.c
+ -mv dbus_bindings.c.gcc4fix dbus_bindings.c