summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f900b021..5d67283b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -44,13 +44,24 @@ break_loader_LDADD= $(TEST_LIBS)
#bus_test_LDADD=$(TEST_LIBS) $(top_builddir)/bus/libdbus-daemon.la
spawn_test_LDADD=$(TEST_LIBS)
+EXTRA_DIST=fix-standard-tests.sh
+
dist-hook:
- DIRS="data data/valid-messages data/invalid-messages data/incomplete-messages data/auth data/sha-1"; \
+ DIRS="data data/valid-messages data/invalid-messages data/incomplete-messages data/auth data/sha-1 data/valid-config-files"; \
for D in $$DIRS; do \
test -d $(distdir)/$$D || mkdir $(distdir)/$$D ; \
done ; \
- FILES=`find -name "*.message" -o -name "*.message-raw" -o -name "*.auth-script" -o -name "*.sha1" -o -name "*.txt"` ; \
+ FILES=`find -name "*.message" -o -name "*.message-raw" -o -name "*.auth-script" -o -name "*.sha1" -o -name "*.txt" -o -name "*.conf"` ; \
for F in $$FILES; do \
echo '-- Disting file '$$F ; \
cp $$F $(distdir)/$$F ; \
done
+
+
+### we want our standard session.conf and system.conf in the test suite,
+### right now we manually sync copies of them over to the test suite
+### from time to time
+update-standard-tests:
+ cp -f $(top_builddir)/bus/system.conf.in data/valid-config-files/system.conf ; \
+ cp -f $(top_builddir)/bus/session.conf.in data/valid-config-files/session.conf ; \
+ $(srcdir)/fix-standard-tests.sh