summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4ddf2603..f0118ee6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,3 +24,13 @@ TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la $(top_bu
echo_client_LDADD=$(TEST_LIBS)
echo_server_LDADD=$(TEST_LIBS)
+dist-hook:
+ DIRS="data data/valid-messages" ; \
+ for D in $DIRS; do \
+ test -d $(distdir)/$D || mkdir $(distdir)/$D ; \
+ done ; \
+ FILES=`find -name "*.message"` ; \
+ for F in $FILES; do \
+ echo '-- Disting file '$$F ; \
+ cp $F $(distdir)/$$F ; \
+ done