summaryrefslogtreecommitdiffstats
path: root/test/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/python/Makefile.am')
-rw-r--r--test/python/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/python/Makefile.am b/test/python/Makefile.am
new file mode 100644
index 00000000..5e4da980
--- /dev/null
+++ b/test/python/Makefile.am
@@ -0,0 +1,11 @@
+## note that TESTS has special meaning (stuff to use in make check)
+## so if adding tests not to be run in make check, don't add them to
+## TESTS
+if DBUS_BUILD_TESTS
+TESTS_ENVIRONMENT=DBUS_TOP_BUILDDIR=$(ABSOLUTE_TOP_BUILDDIR)
+TESTS=run-test.sh
+else
+TESTS=
+endif
+
+EXTRA_DIST=run-test.sh test-service.py test-client.py