summaryrefslogtreecommitdiffstats
path: root/test/qt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/qt/Makefile.am')
-rw-r--r--test/qt/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/test/qt/Makefile.am b/test/qt/Makefile.am
new file mode 100644
index 00000000..553accd4
--- /dev/null
+++ b/test/qt/Makefile.am
@@ -0,0 +1,26 @@
+INCLUDES=-I$(top_srcdir) -I$(top_srcdir)/qt $(DBUS_CLIENT_CFLAGS) $(DBUS_QT_CFLAGS) $(DBUS_QTESTLIB_CFLAGS) -DDBUS_COMPILATION
+
+if DBUS_BUILD_TESTS
+TEST_BINARIES=qdbusconnection
+TESTS=
+else
+TEST_BINARIES=
+TESTS=
+endif
+
+
+noinst_PROGRAMS= $(TEST_BINARIES)
+
+qdbusconnection_SOURCES= \
+ tst_qdbusconnection.cpp
+
+$(top_srcdir)/test/qt/tst_qdbusconnection.cpp: tst_qdbusconnection.moc
+
+TEST_LIBS=$(DBUS_QTESTLIB_LIBS) $(top_builddir)/qt/libdbus-qt-1.la
+
+qdbusconnection_LDADD=$(TEST_LIBS)
+
+CLEANFILES=tst_qdbusconnection.moc
+
+%.moc: %.cpp
+ $(QT_MOC) $< > $@