summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 00000000..f1f9dbac
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS)
+
+if HAVE_GLIB
+GLIB_TOOLS=dbus-monitor
+else
+GLIB_TOOLS=
+endif
+
+bin_PROGRAMS=dbus-send $(GLIB_TOOLS)
+
+dbus_send_SOURCES= \
+ dbus-send.c
+
+dbus_monitor_SOURCES= \
+ dbus-monitor.c
+
+dbus_send_LDADD= $(top_builddir)/dbus/libdbus-1.la
+dbus_monitor_LDADD= $(top_builddir)/glib/libdbus-glib-1.la