summaryrefslogtreecommitdiffstats
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-05-09 23:20:43 +0000
committerLennart Poettering <lennart@poettering.net>2004-05-09 23:20:43 +0000
commit63d51b566ea270b45b5b34b1feab37b8faa28232 (patch)
tree42b190637551ceae31982f2591bec64c7b0b370a /helper/Makefile.am
parentad9b08e8c6fb69636812a625e341ebbe83460a23 (diff)
main fieryfilter worktrunk@31
git-svn-id: file:///home/lennart/svn/public/fieryfilter/fieryfilter@31 79e6afc9-17da-0310-ae3c-b873bff394f4
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
new file mode 100644
index 0000000..4f324fa
--- /dev/null
+++ b/helper/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = \
+ -I/usr/include/libipq -Wall \
+ @PACKAGE_CFLAGS@
+
+EXTRA_DIST = xml-iptables xml-iptables-safe
+
+bin_PROGRAMS = install-firewall
+
+bin_SCRIPTS = xml-iptables xml-iptables-safe
+
+install_firewall_SOURCES = \
+ install-firewall.c
+
+install_firewall_LDADD = @PACKAGE_LIBS@
+
+install-exec-hook:
+ chown root $(bindir)/install-firewall
+ chmod u+s $(bindir)/install-firewall
+
+setuid: install-firewall
+ chown root install-firewall
+ chmod u+s install-firewall