summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 0000000..8b6f709
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,26 @@
+## Process this file with automake to produce Makefile.in
+
+INCLUDES = \
+ -I/usr/include/libipq -Wall \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ @PACKAGE_CFLAGS@
+
+bin_PROGRAMS = fieryfilter
+
+fieryfilter_SOURCES = \
+ ruleset.c ruleset.h \
+ main.c main.h \
+ support.c support.h \
+ interface.c interface.h \
+ callbacks.c callbacks.h \
+ connection.c connection.h \
+ daemon.c daemon.h \
+ mainwin.c mainwin.h \
+ rulewin.c rulewin.h \
+ log.c log.h \
+ format.c format.h \
+ rule.c rule.h \
+ advancedwin.c advancedwin.h
+
+fieryfilter_LDADD = @PACKAGE_LIBS@ $(INTLLIBS) -lmcheck