summaryrefslogtreecommitdiffstats
path: root/helper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
new file mode 100644
index 0000000..4f324fa
--- /dev/null
+++ b/helper/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = \
+ -I/usr/include/libipq -Wall \
+ @PACKAGE_CFLAGS@
+
+EXTRA_DIST = xml-iptables xml-iptables-safe
+
+bin_PROGRAMS = install-firewall
+
+bin_SCRIPTS = xml-iptables xml-iptables-safe
+
+install_firewall_SOURCES = \
+ install-firewall.c
+
+install_firewall_LDADD = @PACKAGE_LIBS@
+
+install-exec-hook:
+ chown root $(bindir)/install-firewall
+ chmod u+s $(bindir)/install-firewall
+
+setuid: install-firewall
+ chown root install-firewall
+ chmod u+s install-firewall