summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-01-21 19:41:45 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-01-21 19:41:45 +0000
commit23b5b27e1c389494a91be3c7226b2bb0e8fb16c5 (patch)
treef9cc72a6ed9f99783115cf7194eafa5ff8466bd4 /tests/check/Makefile.am
parenta973a4f154d9e17ed6551f3511f6a2bdc38f580f (diff)
tests/check/Makefile.am: Fix up some CFLAGS sets.
Original commit message from CVS: * tests/check/Makefile.am: Fix up some CFLAGS sets. Don't include gconfvideosrc in the states test. * tests/check/elements/autodetect.c: (GST_START_TEST): Add some error strings to fail_unless arguments to fix some weird compiler errors on Solaris.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 8ee7b995..842589f1 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -11,7 +11,7 @@ TESTS_ENVIRONMENT = \
GST_PLUGIN_SYSTEM_PATH= \
GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(top_builddir)/sys:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR) \
GST_TEST_FILES_PATH=$(TEST_FILES_DIRECTORY) \
- STATE_IGNORE_ELEMENTS="aasink autovideosink cacasink cairotextoverlay"
+ STATE_IGNORE_ELEMENTS="aasink autovideosink cacasink cairotextoverlay gconfvideosrc"
# ths core dumps of some machines have PIDs appended
CLEANFILES = core.* test-registry.*
@@ -100,18 +100,18 @@ elements_audiopanorama_CFLAGS = \
$(GST_BASE_CFLAGS) $(GST_CONTROLLER_CFLAGS) \
$(CFLAGS) $(AM_CFLAGS)
-elements_cmmldec_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS)
-elements_cmmlenc_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS)
+elements_cmmldec_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
+elements_cmmlenc_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
-elements_alphacolor_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS)
+elements_alphacolor_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
elements_sunaudio_CFLAGS = \
- $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) \
$(AM_CFLAGS)
elements_sunaudio_LDADD = \
$(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-@GST_MAJORMINOR@ \
$(LDADD)
elements_videocrop_LDADD = $(LDADD) $(GST_BASE_LIBS)
-elements_videocrop_CFLAGS = $(CFLAGS) $(AM_CFLAGS) $(GST_BASE_CFLAGS)
+elements_videocrop_CFLAGS = $(GST_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)