summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-06-12 20:15:29 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-12 20:15:29 +0000
commitbbcc24410daed9b6cbbe0efac8d28c4ff4f7da0f (patch)
tree9fe7951f6f0cf989cfad6d5e0eb660d2042d60c2 /tests/check/Makefile.am
parent98ef159bd144b4c50e5c5bad59abc4c180ff1e79 (diff)
Move videocrop and osxvideo from -bad.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/inspect/plugin-videocrop.xml: * gst-plugins-good.spec.in: * sys/Makefile.am: * tests/check/Makefile.am: * tests/icles/Makefile.am: * tests/icles/videocrop-test.c: Move videocrop and osxvideo from -bad.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 7357468c..195f0373 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -62,6 +62,7 @@ check_PROGRAMS = \
elements/level \
elements/matroskamux \
elements/icydemux \
+ elements/videocrop \
elements/videofilter \
$(check_sunaudio) \
$(check_taglib) \
@@ -80,7 +81,10 @@ AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
# valgrind testing
-VALGRIND_TESTS_DISABLE = $(VALGRIND_TO_FIX)
+# videocrop disabled since it takes way too long in valgrind
+VALGRIND_TESTS_DISABLE = \
+ elements/videocrop \
+ $(VALGRIND_TO_FIX)
SUPPRESSIONS = $(top_srcdir)/common/gst.supp
@@ -103,3 +107,7 @@ elements_sunaudio_CFLAGS = \
elements_sunaudio_LDADD = \
$(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-@GST_MAJORMINOR@ \
$(LDADD)
+
+elements_videocrop_LDADD = $(LDADD) $(GST_BASE_LIBS)
+elements_videocrop_CFLAGS = $(CFLAGS) $(AM_CFLAGS) $(GST_BASE_CFLAGS)
+