summaryrefslogtreecommitdiffstats
path: root/ext/pulse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/pulse/Makefile.am')
-rw-r--r--ext/pulse/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/ext/pulse/Makefile.am b/ext/pulse/Makefile.am
new file mode 100644
index 00000000..b16871e6
--- /dev/null
+++ b/ext/pulse/Makefile.am
@@ -0,0 +1,25 @@
+plugin_LTLIBRARIES = libgstpulse.la
+
+libgstpulse_la_SOURCES = \
+ plugin.c \
+ pulsemixer.c \
+ pulsemixerctrl.c \
+ pulsemixertrack.c \
+ pulseprobe.c \
+ pulsesink.c \
+ pulsesrc.c \
+ pulseutil.c
+
+libgstpulse_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(PULSE_CFLAGS)
+libgstpulse_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR) $(PULSE_LIBS)
+libgstpulse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ pulsemixerctrl.h \
+ pulsemixer.h \
+ pulsemixertrack.h \
+ pulseprobe.h \
+ pulsesink.h \
+ pulsesrc.h \
+ pulseutil.h
+