summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 22 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1bd1fae..8027091 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,14 +1,34 @@
+# $Id$
+#
+# This file is part of gst-polyp.
+#
+# gst-polyp is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# gst-polyp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with gst-polyp; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
plugindir=/tmp/
-plugin_LTLIBRARIES = libgstpolyp.la
+pkglib_LTLIBRARIES = libgstpolyp.la
libgstpolyp_la_SOURCES = plugin.c polypsink.c
libgstpolyp_la_CFLAGS = $(GST_CFLAGS) $(POLYP_CFLAGS)
libgstpolyp_la_LIBADD = $(POLYP_LIBS) $(GST_LIBS)
+install-exec-hook: reg
reg:
- gst-register-0.8 --gst-plugin-path=`pwd`
+ gst-register-0.8 --gst-plugin-path=$(pkglibdir)
inspect:
gst-inspect-0.8 polypsink