summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1bd1fae
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+plugindir=/tmp/
+
+plugin_LTLIBRARIES = libgstpolyp.la
+
+libgstpolyp_la_SOURCES = plugin.c polypsink.c
+libgstpolyp_la_CFLAGS = $(GST_CFLAGS) $(POLYP_CFLAGS)
+libgstpolyp_la_LIBADD = $(POLYP_LIBS) $(GST_LIBS)
+
+
+reg:
+ gst-register-0.8 --gst-plugin-path=`pwd`
+
+inspect:
+ gst-inspect-0.8 polypsink
+
+.PHONY: reg inspect