summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-09-13 00:43:14 +0000
committerLennart Poettering <lennart@poettering.net>2003-09-13 00:43:14 +0000
commit22daaf6b7fc3e12a0605a7bb31aba148ed5ba936 (patch)
tree2ec8fe89eecc744f519d108565b03855ca78df49 /man/Makefile.am
parentfb9d6daef0339b7a38ec35c0f7bbc0b5d937d413 (diff)
XSL man pages
git-svn-id: file:///home/lennart/svn/public/ifplugd/trunk@41 2bf48fe7-cfc1-0310-909f-d9042e1e0fef
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am32
1 files changed, 23 insertions, 9 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 4674296..742e3bf 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -18,19 +18,33 @@
man_MANS = ifplugd.8 ifplugd.conf.5 ifstatus.8
-EXTRA_DIST = $(man_MANS) ifplugd.8.xml.in ifplugd.conf.5.xml.in ifstatus.8.xml.in
+noinst_DATA = ifplugd.8.xml ifplugd.conf.5.xml ifstatus.8.xml
-if USE_XMLTOMAN
+EXTRA_DIST = $(man_MANS) ifplugd.8.xml.in ifplugd.conf.5.xml.in ifstatus.8.xml.in man.css man.xsl
-CLEANFILES = $(man_MANS)
+CLEANFILES = ifplugd.8.xml ifplugd.conf.5.xml ifstatus.8.xml
-ifplugd.8: ifplugd.8.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< | xmltoman - > $@
+ifplugd.8.xml: ifplugd.8.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
-ifplugd.conf.5: ifplugd.conf.5.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< | xmltoman - > $@
+ifplugd.conf.5.xml: ifplugd.conf.5.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
-ifstatus.8: ifstatus.8.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< | xmltoman - > $@
+ifstatus.8.xml: ifstatus.8.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+if USE_XMLTOMAN
+
+CLEANFILES += $(man_MANS)
+
+ifplugd.8: ifplugd.8.xml Makefile
+ xmltoman $< > $@
+
+ifplugd.conf.5: ifplugd.conf.5.xml Makefile
+ xmltoman $< > $@
+
+ifstatus.8: ifstatus.8.xml Makefile
+ xmltoman $< > $@
+
endif
+