summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cf41128..596e9bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,6 @@ AC_INIT([ifplugd], [0.16], [mzvscyhtq@itaparica.org])
AC_CONFIG_SRCDIR([src/ifplugd.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
-AM_MAINTAINER_MODE
# Checks for programs.
AC_PROG_CXX
@@ -35,6 +34,11 @@ if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
+if test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ AC_PREFIX_DEFAULT([/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}])
+fi
+
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
@@ -61,7 +65,7 @@ AC_FUNC_SELECT_ARGTYPES
AC_FUNC_MALLOC
AC_TYPE_SIGNAL
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([alarm dup2 memset select setenv socket strchr strdup strerror strrchr])
+AC_CHECK_FUNCS([alarm dup2 memset select setenv socket strchr strdup strerror strrchr strspn])
# LYNX documentation generation
AC_ARG_ENABLE(lynx,