summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-19 13:26:55 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-19 13:26:55 +0000
commite4c3dc5c0d1dc9cdd47fdb4ffb1ac49b9b768e5b (patch)
tree1517947448ad0dc962770f5636efb1a520ded994 /doc/Makefile.am
parent2db4e16e39a91180dae55014176b20efa0b0c686 (diff)
prelimernary documentation
git-svn-id: file:///home/lennart/svn/public/ivam2/trunk@42 dbf6933d-3bce-0310-9bcc-ed052ba35b35
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 34fa300..8a8f63f 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,5 @@
# $Id$
-#
+
# This file is part of ivam2.
#
# ivam2 is free software; you can redistribute it and/or modify it
@@ -16,6 +16,21 @@
# along with ivam2; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-pkgdata_DATA = README.VoiceBox
+noinst_DATA = README.html README
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in README.VoiceBox REQUIREMENTS TODO
+
+MAINTAINERCLEANFILES = README README.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -e < README.html
+
+.PHONY: tidy
-EXTRA_DIST = README README.VoiceBox TODO REQUIREMENTS