summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-19 13:26:55 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-19 13:26:55 +0000
commite4c3dc5c0d1dc9cdd47fdb4ffb1ac49b9b768e5b (patch)
tree1517947448ad0dc962770f5636efb1a520ded994 /man/Makefile.am
parent2db4e16e39a91180dae55014176b20efa0b0c686 (diff)
prelimernary documentation
git-svn-id: file:///home/lennart/svn/public/ivam2/trunk@42 dbf6933d-3bce-0310-9bcc-ed052ba35b35
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..3e30491
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,48 @@
+# $Id$
+
+# This file is part of ivam2.
+#
+# ivam2 is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# ivam2 is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ivam2; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+SUFFIXES=.xml .xml.in .8 .5 .8.xml .5.xml
+
+pkgsysconfdir=$(sysconfdir)/@PACKAGE@
+
+man_MANS = ivamd.8 msntab.5
+
+noinst_DATA = ivamd.8.xml msntab.5.xml
+
+EXTRA_DIST = $(man_MANS) ivamd.8.xml.in msntab.5.xml.in xmltoman.css xmltoman.xsl xmltoman.dtd
+
+CLEANFILES = ivamd.8.xml msntab.5.xml
+
+.xml.in.xml: Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
+ -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@sbindir\@,$(sbindir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+if USE_XMLTOMAN
+
+CLEANFILES += $(man_MANS)
+
+.8.xml.8: Makefile
+ xmltoman $< > $@
+
+.5.xml.5: Makefile
+ xmltoman $< > $@
+
+endif