summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3d03e36
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+# $Id$
+#
+# This file is part of libao-polyp.
+#
+# libao-polyp is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libao-polyp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libao-polyp; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh
+#README LICENSE
+SUBDIRS=src
+# doc
+
+#MAINTAINERCLEANFILES=README
+#noinst_DATA = README
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/paman
+ cp *.tar.gz $$HOME/homepage/private/projects/paman
+ cp doc/README.html doc/screenshot.png doc/style.css $$HOME/homepage/private/projects/paman
+ cp $$HOME/homepage/private/projects/paman/README.html $$HOME/homepage/private/projects/paman/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck